[[oktatas:hálózat:cisco|< Cisco]]
====== Link aggregáció ======
* **Szerző:** Sallai András
* Copyright (c) Sallai András, 2017
* Licenc: [[https://creativecommons.org/licenses/by-sa/4.0/|CC Attribution-Share Alike 4.0 International]]
* Web: https://szit.hu
===== Portok egyesítése =====
A link aggregáció kapcsolatok egyesítéseként fordíthatnánk,
de valójában a portokon állítjuk be, ezért nevezhetjük őket
portok egyesítésének.
==== ====
\ \ / /
\ \ / /
\ \ / /
\ \/ /
=====
||||
||||
A redundáns kapcsolatokban az STP blokkolja az egyik vonal használatát,
a hurkok elkerülése érdekében. A másik viszont kihasználatlan.
Erre lehet megoldás az EtherChannel.
==== EtherChannel ====
A EtherChannel cisco fejlesztés.
Ha beállítottuk az EtherChanelt létrejön egy virtuális
interfész, amit port-csatorna néven emlegetünk.
==== Korlátok ====
* a különböző típusú interfészek nem keverhetők
* FastEthernet <-> GigabitEthernet
* maximum 8 port, Cisco IOS-en max. 6
* a portoknak azonos konfigurációval kell rendelkezniük
==== PAgP ====
A PAgP, a Port Aggregation Protocol rövidítése.
==== LACP ====
Az LACP, a Link Aggregation Control Protocol rövidítése.
==== Beállítás LACP-vel ====
f0/1
S1 ----------------- S2
===== =====
-----------------
f0/2
S1(config)# interface range FastEthernet0/1 - 2
S1(config-if-range)# channel-group 1 mode active
S1(config-if-range)# interface port-channel 1
S1(config-if)# switchport mode trunk
S1(config-if)# switchport trunk allowed vlan 1,2,20
Ellenőrzés:
S1# show etherchannel summary
S1# show etherchannel summary
===== PAgP beállítása =====
S1(config)# interface range FastEthernet0/1 - 2
S1(config-if-range)# channel-group 1 mode desirable
S1(config-if-range)# no shutdown
S3(config)# interface range FastEthernet0/1 - 2
S3(config-if-range)# channel-group 1 mode auto
S3(config-if-range)# no shutdown
Ellenőrzés:
S1# show run interface f0/3
S1# show interfaces f0/3 switchport
S1# show etherchannel summary
Trönk beállítása:
S1(config)# interface port-channel 1
S1(config-if)# switchport mode trunk
S1(config-if)# switchport trunk native vlan 99
S3(config)# interface port-channel 1
S3(config-if)# switchport mode trunk
S3(config-if)# switchport trunk native vlan 99
===== LACP beállítása =====
S1 és S2 között LACP:
S1(config)# interface range f0/1-2
S1(config-if-range# switchport mode trunk
S1(config-if-range# switchport trunk native vlan 99
S1(config-if-range# channel-group 2 mode active
S1(config-if-range# no shutdown
S2(config)# interface range f0/1-2
S2(config-if-range# switchport mode trunk
S2(config-if-range# switchport trunk native vlan 99
S2(config-if-range# channel-group 2 mode passive
S2(config-if-range# no shutdown
S2 és S3 között LACP:
S2(config)# interface range f0/3-4
S2(config-if-range# switchport mode trunk
S2(config-if-range# switchport trunk native vlan 99
S2(config-if-range# channel-group 3 mode active
S2(config-if-range# no shutdown
S3(config)# interface range f0/1-2
S3(config-if-range# switchport mode trunk
S3(config-if-range# switchport trunk native vlan 99
S3(config-if-range# channel-group 3 mode passive
S3(config-if-range# no shutdown
===== EtherChannel ellenőrzése =====
S1# show interface port-channel
S1# show etherchannel summary
S1# show etherchannel port-channel
S1# show interfaces etherchannel